Uploaded image for project: ' AGL Development'
  1. AGL Development
  2. SPEC-501

Security build flags are not enabled in meta-agl-distro/conf/distro/poky-agl.conf

    XMLWordPrintable

    Details

      Description

      Poky proposes some default security flags to be used at build time (see Yocto Mega Manual).

      A discussion has been led in the mailing list and finally the flags were added in this commit.

      But when migrating to Poky 2.1/krogoth, the flags were removed in this commit.

      We should consider re-enabling the security flags.

      Also, some overrides in meta-agl/meta-agl-distro/conf/distro/poky-agl.conf may not be required anymore:

      # required overrides, upstreamed but not merged yet:
      # http://lists.openembedded.org/pipermail/openembedded-devel/2016-June/107727.html
      #SECURITY_CFLAGS_pn-llvm3.3 = "${SECURITY_NO_PIE_CFLAGS}"
      SECURITY_STRINGFORMAT_pn-gpm = ""
      SECURITY_CFLAGS_pn-libdbus-c++ = ""
      SECURITY_LDFLAGS_pn-libdbus-c++ = ""
      

        Attachments

          Issue Links

          No reviews matched the request. Check your Options in the drop-down menu of this sections header.

            Activity

              People

              Assignee:
              sdesneux St├ęphane Desneux
              Reporter:
              sdesneux St├ęphane Desneux
              Votes:
              0 Vote for this issue
              Watchers:
              5 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: