Uploaded image for project: ' AGL Development'
  1. AGL Development
  2. SPEC-4083

speaker-test hangs in case of nosmp

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Open (View Workflow)
    • Priority: Major
    • Resolution: Unresolved
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None
    • Environment:
      AGL LL 12.0.1
    • Hardware Platform(s) Affected:
      Renesas H3

      Description

      I use AGL Reference Hardware board, build commands

      aglsetup.sh -m h3ulcb agl-refhw-h3 agl-demo agl-devel
      bitbake agl-demo-platform-qa
      

      I add nosmp to bootargs.

      Then running

      $ speaker-test
      
      speaker-test 1.2.1
      
      Playback device is default
      Stream parameters are 48000Hz, S16_LE, 1 channels
      Using 16 octaves of pink noise
      Rate set to 48000Hz (requested 48000Hz)
      Buffer size range from 128 to 2097152
      Period size range from 64 to 1048576
      Using max buffer size 2097152
      Periods = 4
      was set period_size = 524288
      was set buffer_size = 2097152
       0 - Mono
      

      hangs.

      I think this can be also be reproduced by removing all CPUs except CPU0 from DT.

        Attachments

        No reviews matched the request. Check your Options in the drop-down menu of this sections header.

          Activity

            People

            Assignee:
            achidipothu Ashok Sidipotu
            Reporter:
            opsyvvavrychuk Vasyl Vavrychuk
            Votes:
            0 Vote for this issue
            Watchers:
            4 Start watching this issue

              Dates

              Created:
              Updated: