Uploaded image for project: ' AGL Development'
  1. AGL Development
  2. SPEC-4079

AGL Compositor not able to access /dev/xen file

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Reopened (View Workflow)
    • Priority: Major
    • Resolution: Unresolved
    • Affects Version/s: Koi 11.0.3
    • Fix Version/s: None
    • Component/s: Graphics
    • Labels:
      None
    • Environment:
      XEN Hypervisor, AGL IVI, NXP i.MX8qm

      Description

      Hello, we are planning to run AGL in XEN hypervisor, and trying to enhance the AGL compositor via XEN functionality which requires to access the device node of /dev/xen/....  But per the test, the display account of AGL-compositor is disallowed to access /dev/xen/... We understood this issue may be per design, but as we are new to AGL so do not know how to grant AGL process with the permission to access /dev/xen/...  So the issue is submitted to request the AGL compositor to allow to access the user defined path such as /dev/xen/...

      We ever tried to modify weston-init and add /dev/xen into tmpfiles.conf.in file, but not work, so can you advise us how to resolve the issue? Thanks a lot

        Attachments

          Issue Links

          No reviews matched the request. Check your Options in the drop-down menu of this sections header.

            Activity

              People

              Assignee:
              mvlad Marius Vlad
              Reporter:
              devin.du quanwen du
              Votes:
              0 Vote for this issue
              Watchers:
              5 Start watching this issue

                Dates

                Created:
                Updated: