Uploaded image for project: ' AGL Development'
  1. AGL Development
  2. SPEC-3993

Stopping web apps causes a crash in WAM

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Open (View Workflow)
    • Priority: Minor
    • Resolution: Unresolved
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None

      Description

      Note, this isn't such a high prio as we're in the process of phasing out AFM but that might awhile.

      Unfortunately don't have a lot of info for it:

      Type "apropos word" to search for commands related to "word"...
      Reading symbols from /usr/bin/WebAppMgr...
      Reading symbols from /usr/bin/.debug/WebAppMgr...
      [New LWP 669]
      [New LWP 607]
      [Thread debugging using libthread_db enabled]
      Using host libthread_db library "/lib/libthread_db.so.1".
      Core was generated by `/usr/bin/web-runtime http://localuser--30:8080/index.html'.
      Program terminated with signal SIGBUS, Bus error.
      #0 0x00000055792b97b5 in ?? ()
      [Current thread is 1 (Thread 0x7f7fffd060 (LWP 669))]
      (gdb) bt
      #0 0x00000055792b97b5 in ?? ()
      #1 0x0000007f803cf000 in ?? () from /lib/libsystemd.so.0
      Backtrace stopped: previous frame inner to this frame (corrupt stack?)

       

      Start a web app then using afm-util to stop it. Should trigger it. 

        Attachments

        No reviews matched the request. Check your Options in the drop-down menu of this sections header.

          Activity

            People

            Assignee:
            rzanoni Roger Zanoni
            Reporter:
            mvlad Marius Vlad
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

              Dates

              Created:
              Updated: