Uploaded image for project: ' AGL Development'
  1. AGL Development
  2. SPEC-1869

afm-util: problems with start/stop/remove

    XMLWordPrintable

    Details

      Description

      Starting an already installed app seems to work:

       

      qemux86-64:~# afm-util list |grep \"id\"
          "id":"mediaplayer@0.1",
          "id":"settings@0.1",
          "id":"dashboard@0.1",
          "id":"homescreen@0.1",
          "id":"phone@0.1",
          "id":"hvac@0.1",
          "id":"launcher@0.1",
          "id":"poi@0.1",
          "id":"mixer@5.99",
          "id":"navigation@0.1",
          "id":"radio@0.1",
      qemux86-64:~# afm-util status dashboard@0.1
      ERROR:  not-found
      qemux86-64:~# afm-util start dashboard@0.1
      1703
      qemux86-64:~# afm-util status dashboard@0.1
      {
        "runid":1703,
        "pids":[
          1703
        ],
        "state":"running",
        "id":"dashboard@0.1"
      }
      

      But then trying to stop it does not seem to work:

      qemux86-64:~# afm-util stop 1703
      ERROR:  not-found
      qemux86-64:~# afm-util stop dashboard@0.1
      ERROR:  not-found
      

      Removing it appears to be successful:

      qemux86-64:~# afm-util remove dashboard@0.1
      null
      qemux86-64:~# afm-util status dashboard@0.1
      ERROR: not-found
      

       But the process is still running:

      qemux86-64:~# pgrep dashboard
      1703
      1704
      

        Attachments

          Issue Links

          No reviews matched the request. Check your Options in the drop-down menu of this sections header.

            Activity

              People

              Assignee:
              jobol-iot jose bollo
              Reporter:
              khilman Kevin Hilman
              Votes:
              0 Vote for this issue
              Watchers:
              6 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: