Uploaded image for project: ' AGL Development'
  1. AGL Development
  2. SPEC-5128

HTML5 applications fail to build after YP scarthgap upgrade

XMLWordPrintable

    • Icon: Bug Bug
    • Resolution: Unresolved
    • Icon: Major Major
    • None
    • master
    • Build and Tools, HTML5/WAM
    • None

      The HTML5 applications pulled in by the HTML5 demo image fail to build after the upgrade to YP 5.0 / scarthgap with variations of this failure:

      ...
      npm ERR! aarch64-agl-linux-g++: error: unrecognized command-line option '-m64'
      npm ERR! make: *** [src/libsass.target.mk:150: Release/obj.target/libsass/src/libsass/src/ast.o] Error 1

      Since there's no sign of '-m64' in the app recipes, this seems like a npm configuration issue.  I will attach the full log.do_compile from html5-homescreen.

        No reviews matched the request. Check your Options in the drop-down menu of this sections header.

            jsmoeller Jan-Simon Moeller
            scottm Scott Murray
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

              Created:
              Updated: