Uploaded image for project: ' AGL Development'
  1. AGL Development
  2. SPEC-3454

webapps / wgts with npm fail to compile on the CI build nodes

    XMLWordPrintable

    Details

      Description

      I think I need some help with npm here:

      https://build.automotivelinux.org/job/ci-apps-html5-mixer-verify-master-CIB-x86-64/6/consoleFull

       

       Child mini-css-extract-plugin node_modules/css-loader/dist/cjs.js!node_modules/sass-loader/dist/cjs.js!src/styles/app.scss:
          Entrypoint mini-css-extract-plugin = *
          [0] ./node_modules/css-loader/dist/cjs.js!./node_modules/sass-loader/dist/cjs.js!./src/styles/app.scss 1.72 KiB {0} [built] [failed] [1 error]
          
          ERROR in ./src/styles/app.scss (./node_modules/css-loader/dist/cjs.js!./node_modules/sass-loader/dist/cjs.js!./src/styles/app.scss)
          Module build failed (from ./node_modules/sass-loader/dist/cjs.js):
          Error: /lib/x86_64-linux-gnu/libm.so.6: version `GLIBC_2.29' not found (required by /w/workspace/ci-apps-html5-mixer-verify-master-CIB-x86-64/html5-mixer/node_modules/node-sass/vendor/linux-x64-57/binding.node)
              at Object.Module._extensions..node (module.js:682:18)
              at Module.load (module.js:566:32)
              at tryModuleLoad (module.js:506:12)
              at Function.Module._load (module.js:498:3)
              at Module.require (module.js:597:17)
              at require (/w/workspace/ci-apps-html5-mixer-verify-master-CIB-x86-64/html5-mixer/node_modules/v8-compile-cache/v8-compile-cache.js:161:20)
              at module.exports (/w/workspace/ci-apps-html5-mixer-verify-master-CIB-x86-64/html5-mixer/node_modules/node-sass/lib/binding.js:19:10)
              at Object.<anonymous> (/w/workspace/ci-apps-html5-mixer-verify-master-CIB-x86-64/html5-mixer/node_modules/node-sass/lib/index.js:14:35)
              at Module._compile (/w/workspace/ci-apps-html5-mixer-verify-master-CIB-x86-64/html5-mixer/node_modules/v8-compile-cache/v8-compile-cache.js:194:30)
              at Object.Module._extensions..js (module.js:664:10)
              at Module.load (module.js:566:32)
              at tryModuleLoad (module.js:506:12)
              at Function.Module._load (module.js:498:3)
              at Module.require (module.js:597:17)
              at require (/w/workspace/ci-apps-html5-mixer-verify-master-CIB-x86-64/html5-mixer/node_modules/v8-compile-cache/v8-compile-cache.js:161:20)
              at getDefaultSassImpl (/w/workspace/ci-apps-html5-mixer-verify-master-CIB-x86-64/html5-mixer/node_modules/sass-loader/dist/index.js:198:10)
              at Object.loader (/w/workspace/ci-apps-html5-mixer-verify-master-CIB-x86-64/html5-mixer/node_modules/sass-loader/dist/index.js:80:29)
      npm ERR! code ELIFECYCLE
      npm ERR! errno 2
      npm ERR! agl-mixer@0.0.0 build: `webpack`
      npm ERR! Exit status 2
      npm ERR! 
      npm ERR! Failed at the agl-mixer@0.0.0 build script.
      npm ERR! This is probably not a problem with npm. There is likely additional logging output above.npm ERR! A complete log of this run can be found in:
      npm ERR!     /home/jenkins/.npm/_logs/2020-06-25T22_08_54_317Z-debug.log
      autobuild/agl/autobuild:85: recipe for target 'build-release' failed
      make: *** [build-release] Error 2

        Attachments

        No reviews matched the request. Check your Options in the drop-down menu of this sections header.

          Activity

            People

            Assignee:
            ltilve Lorenzo Tilve
            Reporter:
            jsmoeller Jan-Simon Moeller
            Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: