Uploaded image for project: ' AGL Development'
  1. AGL Development
  2. SPEC-2251

Inconsistent behaviour in guppy agl-demo-platform for bbe & raspberrypi3

    XMLWordPrintable

    Details

      Description

      I've been testing the agl-demo-platform image built from the guppy branch on both the Sancloud BBE and the Raspberry Pi 3. On both devices I'm getting inconsistent behaviour. Sometimes the system boots and works as expected. More often than not though I see one of the following failure modes:

      • Blank screen.
      • Launcher screen with top & bottom bars shows up correctly but clicking the app icons does nothing.
      • The launcher shows up with all icons, but no top bar or bottom bar is visible on the screen.
      • The top and bottom bars show up but there is no launcher in the middle. Trying to click any of the app icons in the top bar does nothing.

      It seems to be fairly random which failure mode I get.

      This issue doesn't occur in flounder so it's definitely related to recent changes. On the BBE the issue seems to be fixed completely be reverting commit 42dbcc0d19bc5571c3e80588139a069128551900 "Improve integration of callsync" in libwindowmanager. On the raspberrypi3 the same change does improve things, giving a working system on most boots but there are still occasional failures to a blank screen.

        Attachments

        # Subject Branch Project Status CR V

          Activity

            People

            Assignee:
            jobol-iot josé bollo
            Reporter:
            paulbarker Paul Barker
            Votes:
            0 Vote for this issue
            Watchers:
            5 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: