Uploaded image for project: ' AGL Development'
  1. AGL Development
  2. SPEC-2074

[chromium68][qemux86_64] Crash launching WAM and browser after EGL_BAD_MATCH

    Details

      Description

      Steps to reproduce (a):

      1. Launch qemux86_64 emulator with virgl.
      2. Check logs

      Expected output: no crash, WebAppMgr process is alive and can be seen in ps.

      Actual output: crash with EGL_BAD_MATCH.

      Launching of shared browser process fails. This is the log in /var/log/messages:

      Dec 19 15:19:27 qemux86-64 daemon.info WebAppMgr[1493]: ## (DEBUG)[virtual int WebRuntimeAGL::run(int, const char**)] WebRuntimeAGL::run
      Dec 19 15:19:27 qemux86-64 daemon.info WebAppMgr[1493]: ## (DEBUG)[virtual int WebRuntimeAGL::run(int, const char**)] WebRuntimeAGL - creating RenderProcessRuntime
      Dec 19 15:19:28 qemux86-64 daemon.info WebAppMgr[1493]: [1219/151928.034740:ERROR:gl_context_egl.cc(200)] eglCreateContext failed with error EGL_BAD_MATCH
      Dec 19 15:19:28 qemux86-64 daemon.info WebAppMgr[1493]: Received signal 11 SEGV_MAPERR 000000000000
      Dec 19 15:19:28 qemux86-64 daemon.info WebAppMgr[1493]: #0 0x7feb1db32cee base::debug::StackTrace::StackTrace()
      Dec 19 15:19:28 qemux86-64 daemon.info WebAppMgr[1493]: #1 0x7feb1b765851 <unknown>
      Dec 19 15:19:28 qemux86-64 daemon.info WebAppMgr[1493]: #2 0x7feb1db330a7 <unknown>
      Dec 19 15:19:28 qemux86-64 daemon.info WebAppMgr[1493]: #3 0x7feb171f0af0 <unknown>
      Dec 19 15:19:28 qemux86-64 daemon.info WebAppMgr[1493]: #4 0x7feb1e5f82cf gl::GLSurfaceEGL::InitializeOneOffCommon()
      Dec 19 15:19:28 qemux86-64 daemon.info WebAppMgr[1493]: #5 0x7feb1be2dd42 <unknown>
      Dec 19 15:19:28 qemux86-64 daemon.info WebAppMgr[1493]: #6 0x7feb1e6037c5 gl::init::InitializeGLOneOffImplementation()
      Dec 19 15:19:28 qemux86-64 daemon.info WebAppMgr[1493]: #7 0x7feb1e603a6b <unknown>
      Dec 19 15:19:28 qemux86-64 daemon.info WebAppMgr[1493]: #8 0x7feb1e603e41 gl::init::InitializeGLNoExtensionsOneOff()
      Dec 19 15:19:28 qemux86-64 daemon.info WebAppMgr[1493]: #9 0x7feb1ed322f6 gpu::GpuInit::InitializeInProcess()
      Dec 19 15:19:28 qemux86-64 daemon.info WebAppMgr[1493]: #10 0x7feb21168c1f <unknown>
      Dec 19 15:19:28 qemux86-64 daemon.info WebAppMgr[1493]: #11 0x7feb1daff565 base::Thread::ThreadMain()
      Dec 19 15:19:28 qemux86-64 daemon.info WebAppMgr[1493]: #12 0x7feb1db40659 <unknown>
      Dec 19 15:19:28 qemux86-64 daemon.info WebAppMgr[1493]: #13 0x7feb171e63e7 <unknown>
      Dec 19 15:19:28 qemux86-64 daemon.info WebAppMgr[1493]: #14 0x7feb1663fc7f clone
      

      Steps to reproduce (b):

      1. Launch browser

      Expected output: browser is visible after a few seconds.

      Actual output: crash with same trace in messages log.

        Attachments

        No reviews matched the request. Check your Options in the drop-down menu of this sections header.

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              jdapena Jose Dapena Paz
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: